Java & Firefox 3.6

Starting with Firefox 3.6, Mozilla (or Sun?) changed the way the Java plugin is handled.

To be short, the old $JAVA_PATH/jre/plugin/i386/ns7/libjavaplugin_oji.so is no more supported.

Instead, you should use the new Next Generation Java Plugin (libnpjp2.so).

Just add this symlink in your firefox plugin directory

ln -s $JAVA_PATH/jre/lib/i386/libnpjp2.so libnpjp2.so

Comments are closed.